Установка
Не удаётся импортировать ключи GPG с keyserver.ubuntu.com с помощью apt-key
apt-key в Advanced package tool (APT) объявлена устаревшей. Вместо неё следует использовать команду gpg. См. статью руководство по установке.
Не удаётся импортировать GPG-ключи с keyserver.ubuntu.com с помощью gpg
- Проверьте, установлен ли у вас
gpg:
Не удается получить deb-пакеты из репозитория ClickHouse с помощью apt-get
- Проверьте настройки брандмауэра.
- Если по какой-либо причине доступ к репозиторию недоступен, загрузите пакеты, как описано в статье руководство по установке, и установите их вручную с помощью команды
sudo dpkg -i <packages>. Также потребуется пакетtzdata.
Не удаётся обновить deb-пакеты из репозитория ClickHouse с помощью apt-get
При выполнении apt-get update вы получаете разные предупреждения
Не удаётся получить пакеты через Yum из-за неверной подписи
Подключение к серверу
- Сервер не запущен.
- Неверные или неожиданные параметры конфигурации.
Сервер не запущен
Проверьте, запущен ли сервер
Проверьте журналы
clickhouse-server по умолчанию находится в /var/log/clickhouse-server/clickhouse-server.log.
Если сервер успешно запустился, вы должны увидеть строки:
<Information> Application: starting up.— Сервер запустился.<Information> Application: Ready for connections.— Сервер работает и готов принимать подключения.
clickhouse-server не удалось запустить из-за ошибки в конфигурации, вы должны увидеть строку <Error> с описанием ошибки. Например:
clickhouse-server, вы увидите следующую запись в журнале:
Просмотр журналов system.d
clickhouse-server нет полезной информации или они вообще отсутствуют, вы можете просмотреть журналы system.d с помощью команды:
Запустите clickhouse-server в интерактивном режиме
clickhouse-server выводит все сообщения о событиях в консоль.
Параметры конфигурации
-
Настройки Docker:
- Если вы запускаете ClickHouse в Docker в сети IPv6, убедитесь, что установлено
network=host.
- Если вы запускаете ClickHouse в Docker в сети IPv6, убедитесь, что установлено
-
Настройки конечной точки.
- Проверьте настройки listen_host и tcp_port.
- По умолчанию ClickHouse server принимает подключения только с localhost.
-
Настройки HTTP-протокола:
- Проверьте настройки протокола для HTTP API.
-
Настройки защищённого подключения.
- Проверьте:
- Настройку tcp_port_secure.
- Настройки SSL certificates.
- При подключении используйте правильные параметры. Например, используйте параметр
port_secureсclickhouse_client.
- Проверьте:
-
Настройки пользователя:
- Возможно, вы используете неверное имя пользователя или пароль.
Обработка запросов
clickhouse-client описание ошибки выводится в консоли. Если вы используете HTTP-интерфейс, ClickHouse отправляет описание ошибки в теле ответа. Например:
clickhouse-client с параметром stack-trace, ClickHouse вернёт трассировку стека сервера с описанием ошибки.
Вы можете увидеть сообщение о разорванном соединении. В этом случае запрос можно повторить. Если соединение разрывается при каждом выполнении запроса, проверьте серверные журналы на наличие ошибок.